Email to Google-hosted domains is bouncing
Incident Report for Truss Education
Resolved
No emails have bounced for the last four hours - the issue appears to be resolved.

We will continue to monitor bounce rates. Any bounced emails are safe to re-send.
Posted Feb 17, 2022 - 00:00 AEDT
Monitoring
Bounce rates are still high but starting to lower after mitigation measures. Email domains hosted by anyone other than Google seem to be operating fine.

We haven't yet identified the root cause.
Posted Feb 16, 2022 - 13:46 AEDT
Investigating
Since roughly 11:30AM Melbourne time today, Feb 16, we are seeing a high bounce rate for emails sent to Google-hosted domains (gmail addresses or domains hosted with Google Apps).

We are investigating the root cause and attempting mitigation in the meantime. Truss RTO clients should check their "Email Bounces" dashboard to see bounced emails and allow re-sending.

We will advise when email bounce rates begin to return to normal and when we have identified and resolved the root cause, however at this stage it looks like the trigger for it may be other clients of our datacentre provider.
Posted Feb 16, 2022 - 12:37 AEDT
This incident affected: Services (Truss Platform, Email Services), Infrastructure (Truss Production Site 1 (Equinix)), and Support (Support Tickets and CRM).