Emails to hotmail.com and other Microsoft services not delivering
Incident Report for Truss Education
Resolved
This problem is now definitively resolved and has been since 1PM AEDT yesterday.

No further blockages have appeared, and all mail has been cleared from the queue since around 3:45PM yesterday.

If you encounter any issues with users claiming not to have received mail, or unexpected bounces from known valid email addresses, please contact Support.
Posted Nov 09, 2021 - 10:43 AEDT
Monitoring
The problem is now largely resolved.

We have confirmed that this does not affect Office365 domains, only Microsoft's free public email services.

We have also lodged a request with Microsoft to clear the block definitively, but since that communication, emails to the services listed are now delivering.

You are clear to re-deliver any emails to these domains and they should arrive without issue.

We will monitor this for the next hour before marking it resolved.
Posted Nov 08, 2021 - 12:54 AEDT
Identified
Despite the blacklist entry resulting from client spam activity last week being removed, Microsoft have chosen to start blocking mail from our outbound servers.

Affected domains include:
- live.com
- hotmail.com
- outlook.com

We are communicating with Microsoft directly to resolve this and will confirm when it is fixed.
Posted Nov 08, 2021 - 12:41 AEDT
This incident affected: Services (Email Services).