Outbound emails delayed by blacklisting
Incident Report for Truss Education
Resolved
This incident has been resolved.
Posted May 27, 2021 - 15:48 AEST
Monitoring
We've confirmed that all IP addresses were removed from blacklists by 4PM on 27 May, and all delayed email has now delivered.

We are still investigating the root cause of this incident.

If you have any customers reporting delayed or missing email delivery please contact support with details of the messages sent and the destination email address(es).
Posted May 27, 2021 - 11:30 AEST
Investigating
We've become aware of some of our outbound email server IPs being added to blacklists. This generally occurs as a result of emails being sent that are picked up by automated systems as spam, or reported as such by end users.

We're investigating to find any specific emails that may have caused this, but for the moment the following destination email domains are known to be affected:

bigpond.com
telstra.com.au
bigpond.net.au
yahoo.com.au

Google and Office365 based domains are not affected, and nor are the majority of other email domains.

Once we've identified the root cause we will contact the client whose emails resulted in this, but in the meantime we are having the IPs delisted and emails will deliver with a delay.
Posted May 26, 2021 - 13:34 AEST
This incident affected: Services (Email Services).